RC.CONF(5) BSD File Formats Manual RC.CONF(5)
rc.conf -- init configuration
The file /etc/rc.conf is sourced by rc.init(1) at boot and the shell
variables defined in it are used to initialize the system. It is a sim-
ple shell script, which should define the special environment variables.
Currently, that includes the following:
FONT passed to setfont(8) on all activated ttys (by de-
FONT_MAP passed with the argument -m to setfont(8).
FONT_UNIMAP passed with the argument -u to setfont(8).
KEYMAP passed to loadkeys(1).
INTERFACE used to bring up an interface with ip(8).
KILLDELAY how long to wait between sending the SIGKILL and
SIGTERM on system shutdown.
LANG default locale for the system. Can be overridden by
the user's shell configuration files.
HOSTNAME system hostname. If not set here, the first line of
the file /etc/hostname will be used, or the fallback
"galeb" if that file is also nonexistant.
TIMEZONE system timezone. If not set here, and the link
/etc/localtime is not present, it will be created
pointing to the file /share/zoneinfo/GMT by default.
Galeb 2.2 April 17, 2023 Galeb 2.2